Subject: Remote `psterm' shell script for NeWS

From: Greg Earle <[email-masked]>
Date: Mon, 26 Oct 87 01:07:12 EST

Here's something you might find handy.  If you have the newer version of
`psterm' that Sam Leffler announced (available via anonymous FTP from host
Columbia.EDU), then toss this into your /usr/NeWS/bin.  See the comments
for what it does.

	Greg Earle		[email-masked]
	S(*CENSORED*)t		[email-masked]	[aka:]
	Rockwell International	[email-masked]
	Seal Beach, CA		...!cit-vax!elroy!jplgodo!mahendo!earle

---------------------------- >8  Cut Here  8< ---------------------------
#!/bin/sh
#
# Remote psterm shell script
# Takes one mandatory argument, namely remote host to execute psterm on
# Optional second argument is terminal type (default h19)
# Sends window back to the current host
# Requires the new Sam Leffler-ized `psterm', sorry (Needs `-bg' to background)
# I think this is the `psterm' that made it into NeWS 1.1
# It is available for anonymous FTP from columbia.EDU
#
PATH=${PATH}:/usr/NeWS/bin: ; export PATH
HOSTNAME=`hostname` ; export HOSTNAME
NEWSHOME=/usr/NeWS/bin ; export NEWSHOME
TTYTYPE=${2-h19} ; export TTYTYPE
if [ $# = 0 ] || [ $# -gt 2 ]
then
	echo usage: rpsterm remote-host [ terminal-type ]
	exit 1
fi
rsh $1 "setenv PATH ${PATH}:$NEWSHOME ; \
	setenv NEWSSERVER '`setnewshost $HOSTNAME`' ; \
	psterm -f -bg -t $TTYTYPE -xy 0 405 -fl 'Remote psterm on $1' -il $1"
unset TTYTYPE
unset HOSTNAME
exit 0

---

From: [email-masked] (Jos Warmer)
Date: Fri, 30 Oct 87 00:49:47 EST

># It is available for anonymous FTP from columbia.EDU

We only got NeWS a short time ago. The version is called 1.0.
Doing some tests, it seems to have several bugs.
It doesn't repond anymore or even dumps core.
Also, a lot of PostScript operetors are not implemented, especially
almost the complete font machinery, which would be very useful to us.

I am wondering: is there really a version 1.1 ?
If so, what is the difference with version 1.0 and how sdoes one get it.

If there is no significanlty better version yet, can anyone at SUN
predict when a more complete and stable version will be avialable.

      Jos Warmer
      Department of Mathematics and Computer Science
      Vrije Universiteit Amsterdam

      email: [email-masked]

---

From: Jim Knutson <[email-masked]>
Date: Fri, 30 Oct 87 11:34:21 EST

Here are a list of 1.1 changes, enhancements, etc.:

o runs on Sun-4 machines

o better font support

o supports the full PostScript font model

o dashed lines work

o PostScript previewing is much better, includes new version of psview

o typing keys repeat

o psterm is faster and has other enhancements

o supports journalling (recording/playing of events)

o psload (load average)

o can create windows with scrollbars and menus in many styles

o allows selections to be transferred between SunView and NeWS

o new demos

Jim Knutson